Status Page
Support:
1-866-300-0884
All Systems Operational
Operational
Degraded Performance
Partial Outage
Major Outage
Maintenance
Status
Scheduled Maintenance
Status History
Upcoming Maintenance
Completed Maintenance
Subscribe to Updates
Subscribe
x
Visit our
support site
.
IMPORTANT: Platform Disruption
Incident Report for
Caregility™ Cloud Platform
Resolved
This incident has been resolved.
Posted
Jan
08
,
2026
-
14:34
UTC
Update
Dear Valued Customer,
The issue with the Platform has been resolved. An RCA will be provided upon our investigation of the root cause.
We will continue to closely monitor. If you experience any further issues, please call Tech Support at 1-866-300-0884.
Sincerely,
The Caregility Team
1-866-300-0884
techsupport@caregility.com
Posted
Jan
08
,
2026
-
14:33
UTC
Investigating
Dear Valued Customer,
We are writing to inform you that our platform is currently experiencing a service disruption. Our team is actively investigating the issue and will provide updates as soon as more information becomes available.
Sincerely,
The Caregility Team
1-866-300-0884
techsupport@caregility.com
Posted
Jan
08
,
2026
-
13:28
UTC
This incident affected: Application Services (iConsult 2.0, iObserver 3.0, Clinical Notifications), Management Services (Admin Portal, Reporting), Mobile Application Services (iConsult 2.0 - iOS, iConsult 2.0 - Android), and Platform Services (Landing).
×
Subscribe to Incident
Subscribe to updates for
IMPORTANT: Platform Disruption
via . You'll receive .